«

»

feb 21 2016

Installazione automatica dei miei core con l’IDE 1.6.7

Da oggi è possibile installare in automatico tutti i miei core (core per ATmega644/1284, core per ATmega168/328 e core per gli ATtiny24/44/84-25/45/85-2313/4313) direttamente dall’IDE 1.6.7 in pochissimi passaggi. Rispetto alla gestione manuale, l’installazione automatica garantisce anche che in caso di aggiornamento sia lo stesso ambiente di sviluppo a segnalare la nuova versione. Per fare ciò, prima di tutto è consigliabile rimuovere i core che avevate eventualmente installato manualmente, poi avviare l’IDE 1.6.7, andare nel menu “File/Preferenze” o “File/Impostazioni” (a seconda del sistema operativo), dopo di che alla riga “URL aggiuntive per il Gestore Schede” cliccare sull’icona alla destra del campo di testo e, nella finestra pop-up che si apre, inserire la seguente riga:

http://www.leonardomiliani.com/repository/package_leonardomiliani.com_index.json

Adesso andate in “Strumenti/Scheda” e poi selezionate la voce “Gestore schede”. Attendete qualche secondo, durante i quali il gestore ricarica da internet l’elenco delle schede aggiuntive, e poi scorrete l’elenco finché non trovate le seguenti voci:

  • Atmega168P/328P Boards by Leonardo Miliani versione x.x.x
  • Atmega644/644P/1284P Boards by Leonardo Miliani versione x.x.x
  • ATtiny extra board by Leonardo Miliani versione x.x.x

Adesso non dovete fare altro che cliccare sul core che vi interessa e poi premere il relativo pulsante “Installa”. Al termine dell’operazione avrete nell’IDE il core installato con le nuove schede disponibili dal menu “Strumenti/Scheda”.

4 comments

Vai al modulo dei commenti

  1. fabiokt88

    Ho tentato invano di caricare il bootloader usando il tuo core aggiornato e l’ultima versione dell’IDE 1.6.7

    Ho usato la board Arduino Uno, precaricando l’ArduinoIsp

    Durante il caricamento del bootloader mi esce questo messaggio:

    avrdude: verification error, first mismatch at byte 0x0000
    0x3f != 0xff

  2. fabiokt88

    Per cortesia mi potresti aiutare a risolvere il problema ?
    Ti ringrazio

  3. Leonardo Miliani

    Ricontrolla i collegamenti, il circuito ed il tipo di chip selezionato.

  4. salvatore993

    ho rimesso mano ad un progetto che realizzai con la versione1.05 e i core con la cartella W40.
    con la nuova versione non carico gli scetch scritti con la precedente, devo importare librerie, file config o altro?

Lascia un commento