nov 05 2016

Bug dell’IDE 1.6.12 può bloccare l’installazione dei pacchetti aggiuntivi

L’IDE 1.6.12 contiene un bug per cui per alcuni utenti vanno incontro ad un errore di CRC errato (la somma di controllo utilizzata per verificare che i pacchetti siano stati stati scaricati in modo corretto) generato dall’IDE che può impedire l’installazione di un pacchetto all’apparenza sano. Ciò dipende dal fatto che se l’IDE ha scaricato una versione precedente di quel pacchetto che ha causato un problema reale di CRC corrotto, da quel momento in poi tutte le volte che l’utente cercherà di installare quella versione avrò quel problema. In attesa dell’uscita della versione 1.6.13 che risolve il problema l’utente ha la possibilità di aggirarlo in 3 modi:

  1. cancellare manualmente il pacchetto dalla cartella Arduino15/staging/packages (solo per utenti esperti);
  2. compilare in proprio l’IDE partendo dai sorgenti seguendo le istruzioni qui riportate (solo per utenti esperti);
  3. scaricare una hourly build dell’IDE di Arduino (una versione dell’IDE compilata ogni ora che contiene tutte le modifiche inserite dai programmatori) da qui: https://www.arduino.cc/en/Main/Software#hourly.

I punti 1) e 2) sono per utenti esperti; per chi è alle prime armi o non conosce bene il processo della compilazione di un programma consiglio di usare una hourly build compilata per il proprio sistema operativo.

Lascia un commento